Share:
Notifications
Clear all

Plugin NotifHeure

Page 1 / 2
byfeel
(@byfeel)
Eminent Member

Forum relatif au plugin NotifHeure .  https://github.com/NextDom/plugin-NotifHeure
Doc : https://nextdom.github.io/plugin-NotiFHeure

Quote
Topic starter Posté : 06/01/2019 10:14
byfeel
(@byfeel)
Eminent Member

Pas encore sur le market nextdom , mais vous pouvez le tester via autre source ( j'ai encore quelques améliorations à faire , mais il fonctionne sur ma plateforme ) .

Il faut renseigner l'adresse IP de votre NotifHeure , et si tout est ok il remonte les commandes et les infos automatiquement.

choisir Github

et renseigner les infos suivantes :

ID logique : NotifHeure

organisation depot : NextDom

nom depot : plugin-NotifHeure

branche : master

RépondreQuote
Topic starter Posté : 06/01/2019 10:23
dcjona
(@dcjona)
Membre Admin

cool merci Phil

RépondreQuote
Posté : 07/01/2019 3:33
byfeel
(@byfeel)
Eminent Member

Si tu as des suggestions ou des bugs n hésite pas.  😀  

RépondreQuote
Topic starter Posté : 07/01/2019 6:16
Esso1-jeedom
(@esso1-jeedom)
Membre Admin

il est sur le market

RépondreQuote
Posté : 08/01/2019 9:06
byfeel
(@byfeel)
Eminent Member

Non ,  toujours,  pas visible , sur le market .

Je ne sais pas , ce qui bloque ?

Mais il est possible de le tester en passant par l'ajout de source manuel , comme expliqué sur les posts précédents.

RépondreQuote
Topic starter Posté : 08/01/2019 3:25
byfeel
(@byfeel)
Eminent Member

C est ok 👍 il vient d être publié sur le market NextDom. 

RépondreQuote
Topic starter Posté : 08/01/2019 6:36
christlep
(@christlep)
Active Member

Salut,

Plugin installé sur jeedom grâce au market Nextdom

J'ai 2 notifheure piloté par jeedom, le premier est en version 3.1.3 avec 12 matrices, le second est en version 3.2.0 avec 12 matrices + capteur luminosité + une led.

Sur le widget du premier notifheure, aucun soucis.

Par contre sur le widget du second, à la place de l'heure j'ai un 1 d'afficher, en dessous à la place de "Mode Manuel" j'ai la encore un 1 d'afficher (il est en mode luminosité automatique) et y a la case DHT d'afficher alors qu'il n'y en a pas et que dans les paramètres c'est bien détecter que le DHT n'est pas présent.

[attach]112,111[/attach]

Ah, un autre truc, par défaut mes widgets sont sur fond noir (je ne sais plus pour quelle raison), et depuis quelques mois, j'ai pris l'habitude de remplacer ce fond noir par un fond transparent à l'aide de l'onglet "affichage" dans les paramètres avancés de l’équipement, mais là l'onglet "affichage" n'apparait pas. Du coup y a des boutons du widget que je ne vois pas, ca ne me dérange pas, mais c'est juste pour faire remonter l'info.

Voila ce que j'ai, pour le moment, pu voir comme bug.

Bonne continuation pour le développement du plugin

A+

chris

This post was modified Il y a 2 années by christlep
RépondreQuote
Posté : 09/01/2019 10:12
byackee
(@byackee)
Admin Admin

Bonjour @christelp

Le fond noir sur les widgets ne serait pas dû a une customisation avancee (CSS/js) ou dans les reglage des couleurs de widgets ?

RépondreQuote
Posté : 10/01/2019 6:58
byfeel
(@byfeel)
Eminent Member

bonjour @chrishelp ,

j'ai corrigé hier soir , afin que l'onglet affichage apparaisse. Tu devrais avoir la mise à jour de disponible.

Au niveau du widget , il semblerait que le script javascript est bloqué ? car les valeurs sont remplacés lors de l'execution du script . Apres , il y a aussi des problémes de caches , qui peuvent jouer , et dans ce cas la le navigateur ne recharge pas tout de suite la page et ne met pas à jour le widget .

Tu peux essayer en vidant le cache du navigateur et recharger la page ?

J'ai en effet des petits problèmes de cache sur les Widget avec jeedom , tu peux essayer aussi de forcer le rafraichissement de ton premier widget ( qui fonctionne bien ) , puis aller sur le second et rafraichir la page , souvent ça corrige le problème en forçant jeedom à faire la mise à jour du cache.

J'envisage de rajouter une option qui permettrait de désactiver le widget personalisé ? mais je ne sais pas comment faire sans supprimer la classe qui gère ça .

This post was modified Il y a 2 années by byfeel
RépondreQuote
Topic starter Posté : 10/01/2019 8:26
christlep
(@christlep)
Active Member

Salut,

J'ai vidé le cache du navigateur = pas de changement

J'ai vidé le cache de jeedom = pas de changement

J'ai fais une install vierge de Nextdom et du plugin, j'ai le même bug sur le deuxième notifheure crée.

[attach]113[/attach]

A+

chris

RépondreQuote
Posté : 10/01/2019 3:53
byfeel
(@byfeel)
Eminent Member

Hello Chris  , le bug apparaît quand on affiche plus de deux notifheure en même temps. Par exemple dans le même objet ou si on affiche le Dashboard complet avec tous les objets. 

Mais si on affiche un objet à la fois avec un notifheure cela fonctionne. 

Merci pour avoir trouvé ce bug. 

Je vais regarder pour corriger ça. 

RépondreQuote
Topic starter Posté : 10/01/2019 8:09
byfeel
(@byfeel)
Eminent Member

C'est bon , j'ai poussé le correctif .... tu essayeras ..

[attach]114[/attach]

RépondreQuote
Topic starter Posté : 11/01/2019 11:47
christlep
(@christlep)
Active Member

Salut,

Mise a jour faite sur Nextdom et c'est nickel 😉

[attach]115[/attach]

Merci Byfeel 😉

Si j'en vois d'autre, je te previens

A+

chris

RépondreQuote
Posté : 11/01/2019 1:39
byfeel
(@byfeel)
Eminent Member

J'ai réalisé une correction ce matin , sur l'affichage des widgets , qui avait tendances à faire disparaitre le petit crayon qui permet de modifier les widget dans la vue dashboard.

RépondreQuote
Topic starter Posté : 12/01/2019 10:47
Page 1 / 2
Share:
fr_FRFrançais
fr_FRFrançais